24/7 Customer Support

CHECKOUT
Items in Cart:
Total
$0.00

Chat with a Pro

Electronic Control Board

Part Number: AP4566308
MFG Part Number: W10285180
Made by: Whirlpool
Our Price
$134.12
Regularly You Save
$160.94 $26.82

In Stock — Ships Friday Guaranteed

Satisfaction Rating (2)

Questions & Answers

62 Questions & Answers



Genuine Whirlpool part. Whirlpool brands include Whirlpool, Maytag, KitchenAid, Jenn-Air, Amana, Magic Chef, Admiral, Norge, Roper, and others. See all items in Dishwasher Control Board.
Whirlpool also makes various appliance models for Sears / Kenmore.

Appliance Compatibility Tool

Check your model number or use our Cross Reference Tool to determine if this part will work with your appliance.

Where can I find my model number?

More Product Images

Repair Help


Cross Reference Information

Part Number W10285180 (AP4566308) replaces W10130967, W10208673, 1874822, PS3407463.

Do-It-Yourself Stories from Customers like You
Total Satisfaction Rating
(2)
View All Do-It-Yourself Stories Have questions? Ask our pros!
Dishwasher not working problem with timer Jill M. • Brandon, MN • June 07, 2014

My Repair & Advice

Was this review helpful to you?  

Most Helpful Stories

1 People found this story helpful
Do-It-Yourself Rating
  • 1
  • 2
  • 3
  • 4
  • 5
Easy Difficult
Repair Time Estimate

15-30 minutes 

Dead electronic control board lights kept flashing and cycle wouldn't finish Laura H. • Pacific Grove, CA • September 09, 2014
Appliance: Model 665 SERIES KENMORE DISHWASHER, UNDER-COUNTER

My Repair & Advice

Was this review helpful to you?  

   
Do-It-Yourself Rating
  • 1
  • 2
  • 3
  • 4
  • 5
Easy Difficult
Repair Time Estimate

Less than 15 minutes 

Have a Repair Question?
AppliancePartsPros has your Answer!

Questions & Answers

Read all 62 Questions

Ask a Question

Most Interesting

A few months back when I pushed button for wash cycle stopped lighting up, when push start/resume - dishwasher ran. Now when I push normal - no lights, start/resume - no lights will not run. when push heavy - lights up but will not run. Will a new circuit board repair?

Bonnie for Model Number MDBH949AWW1

Answer

Was this helpful?

Have dishwasher in a rental, tenant said last several loads have come out covered with dry soap. Ran through a cycle today and watched it's operation. Unit starts, fills with water, dispenses soap and runs what appears to be normally with the "wash" indicator light lit. Unit continues to run what seems to be a normal duration and shuts off, but "clean" indicator light does not come on and dishes are covered with a heavy soapy residue. All water seems to be filling and draining properly. Unit does not appear to be going through any type of rinse cycle. Trying to determine which electronic part had gone bad, seems like there are only two. Thanks

Matt P. for Model Number ADB1600AWW1

Answer

Was this helpful?

DIL's 665 series Kenmore D/W. Control board W10285180. Will not fill or wash. Goes directly to dry after cycle start. Every time, hard failure. Diagnostic mode heat-normal-heat-normal accepted. All lights light EXCEPT wash led. Overfill float checked visually underneath, seems OK, clicks, operates, not tested for continuity yet. All keys appear OK. Control board?

Tom B for Model Number 665.13463K902

Answer

Was this helpful?

Latest Questions

My unit will only run for about 5 minutes before shutting off. The lights and buttons appear to work, but I have to constantly press start to finish a cycle. I disconnected power and that managed to remedy the problem for about a day or so. Wondering what I should try replacing first? Thanks!

Kevin for Model Number MDB6769AWS3

Answer

Was this helpful?

My soap dispenser opens fully and releases all the soap during the first cycle rather than the first cycle only getting what seeps out. Any suggestions ?

Shawn for Model Number GU2275XTVY0

Answer

Was this helpful?

I have a Maytag type 577-0, mod MD87749AWB1. All of a sudden, when I push the cycle select buttons on the control panel, they do not light up. If I push the start button, I get normal cycle, high temp wash, heated dry. This is the cycle we most frequently use. I can select rinse only. And once I push the Start button, all lights seem to function normally. But can't select heavy or light or de-select high temp wash. It seems to run through either normal wash cycle or rinse only correctly. I tired to lock and unlock the panel buttons (hold down the Heated Dry button) and turned off the circuit breaker for a minute, then back on. No affect. What's up?

Stanley G for Model Number MD87749AWB1

Answer

Was this helpful?