24/7 Customer Support

CHECKOUT
Items in Cart:
Total
$0.00

Chat with a Pro

Motor-Drive

Part Number: AP3178622
MFG Part Number: 8541504
Made by: Whirlpool
Our Price
$200.46
Regularly You Save
$240.55 $40.09

In Stock — Ships Today Guaranteed

Questions & Answers

6 Questions & Answers



Genuine Whirlpool part. Whirlpool brands include Whirlpool, Maytag, KitchenAid, Jenn-Air, Amana, Magic Chef, Admiral, Norge, Roper, and others. See all items in Washer Motor.
Whirlpool also makes various appliance models for Sears / Kenmore.

Appliance Compatibility Tool

Check your model number or use our Cross Reference Tool to determine if this part will work with your appliance.

Where can I find my model number?

More Product Images

Repair Help


Cross Reference Information

Part Number 8541504 (AP3178622) replaces 962140, AH888068, EA888068, PS888068.

Have a Repair Question?
AppliancePartsPros has your Answer!

Questions & Answers

Ask a Question

Most Interesting

Washer was running fine and all the sudden it stopped in the middle of a rinse cycle. Took the motor out and replaced with same model number bought from the site. After installing the motor would make a loud humming noise and would eventually start, with no cloths only water. Put a small load of cloths in and the washer seemed to work fine. I was checking the machine while in the middle of a agitator cycle and opened the lid to check for any leaks, and now the machine will do nothing. I can adjust the know and the motor will hum loudly again but will never spin. Any help will be grateful.

Washer Noob for Model Number Kenmore 110.23014102

Answer

Was this helpful?

Kenmore washer motor makes hiccupping sound. Disconnected motor from transmission and laid it on floor to test. Replaced timer...still same problem. Replaced motor with 8541504 and still the hiccuping where the motor spins but hiccups every split second. Don't know what else to replace..... Thanks, Larry

Larry for Model Number 110.24042301

Answer

Was this helpful?

Water is not draining out of tub after the rinse cycle. I disassembled the pump and it appears to be OK, turns freely & is not leaking. I removed the drive motor to check the coupling and the coupling is in excellent shape. The tub agitates and spins, the water just isn't draining completely, although some of it does. Is this an electrical problem, such as the motor's not getting a signal to turn the pump, or what? Thanks for any answers or recommendations you might have.

Bob for Model Number Kenmore 110.23014102

Answer

Was this helpful?

Latest Questions

Had a load of laundry in washing and the machine just stopped along with the strong!!! smell of an electric fire. Did the motor just burn out? After looking in the back, motor assembly was very very hot, nothing else seemed out of place. Thanks.

Donw. for Model Number 11024942300

Answer

Was this helpful?

I forgot to mention i replaced the transmission. From last question and answer

Andy for Model Number 110.24952300

Answer

Was this helpful?

Washer won't spin most the time. I replaced the direct drive washer, motor coupling, agitator repair kit, drive block for inter tub. Should I replace the motor? Please Help Andy

Andy for Model Number 110.24952300

Answer

Was this helpful?